Replies: 10 (Who?), Viewed: 8104 times.
Mad Poster
Original Poster
#1 Old 5th Aug 2017 at 9:03 PM Last edited by gazania : 10th Aug 2017 at 11:25 AM.
Default OK. I'm stumped. Why is this happening?
I've been making something for this recent theme as kind of a play-along ... if the lot turns out somewhat decent, I'll give this a try here; if not, I still have a building for ... stuff ... , but I've hit a snag.

What on earth would cause a lot to dip like this with all cheats off? And only on part of ONE side?

Fortunately, it's an easy fix, it seems ... just put tiles outside of the affected area and level it out. So that's the good news. I can still use the lot privately. But I'd be reluctant to share this if this problem persists.

Some points ....

This lot will probably not look it, but I used cheats like mad ... move_objects, snap_objects, CFE for the dummy roof. I have repeatedly made sure all cheats are off. Over and over.

The foundation is sunken, but since this only happens on one side, I don't think it's that ... and I've never seen this in all my two-step-foundation lots I've made over the years. I've made many.

The lot was flat before I started. I made sure before building. I leveled out the lot just now in case during troubleshooting.

The problem happens ONLY on most of one side ... and not even on the entire side. The other three are fine. And it happens only when I alter the light purple tiles on the edge closest to the wall to the left (the side shown in the picture). Any other tiles are fine.

If I don't level the outside using tiles, I can't use terrain, and sometimes, the foundation will even dip. And again ... I've made sure that every cheat I turned off is still off.

If I move the lot to the bin and move it elsewhere, I still have the problem.

I do not believe there are any objects stuck in the way during a move_object cheat that could cause this. However, I don't entirely rule that out, even if I don't see any out of place. The side has those really thin Maxis neon bars that I move_objected. Even if I did, I don't think I'd mess up most of an ENTIRE side.

So ... what am I not seeing here? In all the years I've built lots, I've never seen this. It's fixable and more of an annoyance, but I haven't a clue how this happened in the first place!

(And this is very, very much a WIP. I'll probably be revising like crazy. I'm far from being done. I just wondering about the dip right now.)

Thanks to ALL free-site creators, admins and mods.

RIP Sunni ... truly a ray of light.
Edge Of Darkness
retired moderator
#2 Old 5th Aug 2017 at 9:24 PM
Perhaps you would share a copy so that I can try it in my game? Might tell us something if it's transferrable between games.

Also, what soes the floor grid on the upper levels look like?

I will choose a path that's clear- I will choose free will
***Sims File Share- ask me for a code***
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
If you are looking for files from old websites the Internet Archive is your best friend.
Mad Poster
Original Poster
#3 Old 6th Aug 2017 at 2:15 AM Last edited by gazania : 6th Aug 2017 at 8:21 AM.
Sorry. Didn't meant to drop off the face of the earth. I got called away.

I can try the lot in my good game as well. I'll also give it another look to see if something is causing a problem. Apparently, whatever I did, I did it on about 3/4 of that side! Right now, someone else is on the computer. It might take a while, but there is no hurry yet, I think.

I would prefer to Orb the lot first before putting it here, and put the lot in still another fresh hood with NSL loaded, cleaning out the references for good measure first. So far, my multiple tests with the Orb hasn't shown anything bad after 17 or so tries (doesn't break out the champagne or fireworks yet, but does break out a carbonated water and a sparkler!), but I would want my lot to be as clean as it can be if someone is testing it. (EDIT ... Try #18. The XML file is clean. No nasty social files that shouldn't be in there.)

Funny, I was about to post the dummy floor level, but didn't see anything odd. I should have ... I might have missed something.

In the meantime ... (looks at a couple of things she wants to fix now that she's looking at the picture and fixes them) ....

EDIT ... While putting the lot in the test hood in my good game (I'm using a test game to make the lot), I noticed a clue. It's in the picture to the right.

I accidentally deleted a window while testing, and went to put it back in. I did not use cheats to insert these windows in the first place. The window looks like I forgot to turn off a cheat. Yet, I've entered move_objects off, boolprop constrainFloorElevation true and boolprop snapobjectstogrid true a few times, thinking that was the cause in the first place. And if I forgot to turn off a cheat, I would think that problem would apply to the other three sides of the building; not just most of one side. That still doesn't make sense.

Thanks to ALL free-site creators, admins and mods.

RIP Sunni ... truly a ray of light.
Mad Poster
Original Poster
#4 Old 6th Aug 2017 at 9:56 AM
Sorry for double-posting, but I think I know what I did wrong.

I am sure ... hopeful, actually ... that someone will disagree and post something telling me I'm wrong and how to fix it, but CFE-ing dummy roofs and dropping the foundation doesn't mix too well. With the possible exception of some of the master builders out there who have figured this out, one or the other can suffer.

I tried dropping the foundation, then CFE-ing and had trouble. I tried doing it the other way around and still had trouble. Doing it the second way undoes your CFE-ing attempts. If you try the stair technique to set up your extra wall and foundation for CFE-ing, you'll find that you'll have trouble with that too. The lot won't take the stairs (kind of makes sense, now that I think about it.) I tried to force the CFE wall/foundation setup by manually clicking. I made several corrections on that side as well, and I think that caused the problem.

I'm going to try it the other way around one more time (drop the foundation/CFE the dummy wall) to see if I missed something. Fortunately, though my pre-shrunk lot was only my first prototype, which means I'll have to fix this like mad to get it to resemble this build, I at least had ONE copy of a prototype binned and packaged. This is why one packages or bins prototypes. Sometimes, CFE-ing or lot adjusting can go terribly wrong, and I think that's the case here. Or I can take a slightly different approach and leave the foundation as is. To be honest, I think there is still plenty of room to improve this. For me, lot prototypes are like manuscript drafts.

Let me see what happens. I'll post the result later.

Thanks to ALL free-site creators, admins and mods.

RIP Sunni ... truly a ray of light.
Needs Coffee
retired moderator
#5 Old 6th Aug 2017 at 10:07 AM
gazania without reading too much, it looks like something that can happen with the CFE cheat active. Just put it on again and using the level tool hold and drag it across your lot, that should fix it.

"I dream of a better tomorrow, where chickens can cross the road and not be questioned about their motives." - Unknown
~Call me Jo~
Mad Poster
Original Poster
#6 Old 6th Aug 2017 at 9:01 PM Last edited by gazania : 10th Aug 2017 at 5:02 PM.
I just wound up re-doing the lot using the previous unshrunk prototype. It turned out that I CFE'd literally one or two clicks lower than I should have on the roof.

A bit of advice if anyone is interested .... if you're going to sink the foundation AND do a dummy-roof, do the sinking first, then the dummy-roofing. I think that's one thing I got wrong. If you do it the other way around, the dummy roof goes right back up, and I found I had a little trouble with it. You might as well not make extra work for yourself!

I'm indeed chalking this one to a CFE gone wrong. After I re-did the lot, the tiles are behaving themselves. No tiles sinking the land outside them, and I can put in and move all the windows I want.

Thanks to ALL free-site creators, admins and mods.

RIP Sunni ... truly a ray of light.
Top Secret Researcher
#7 Old 13th Aug 2017 at 10:46 PM
I'm curious, gazania, did you use Mootilda's Grid Adjuster on this Lot (since it looks like it has a +2 click foundation)?
And why shrink the Lot (since it looks like a normal 2x2 and none of the walls extend to the edge of the Lot)?
Mad Poster
Original Poster
#8 Old 17th Oct 2017 at 5:38 AM
It's been two months. I'm probably committing necromancy. But it would be pretty rude of me to ignore that last post, even if I did upload this some time ago. Sorry, ScaryRob! Somehow, your post slipped under the radar for me.

Yes, I used Grid Adjuster. And I changed the size of the lot pictured here because I didn't like the original lot size and scaled it down. It turned out I made a whole new version toward the end from the ground up anyway, so it was a moot point.

Thanks to ALL free-site creators, admins and mods.

RIP Sunni ... truly a ray of light.
Top Secret Researcher
#9 Old 18th Oct 2017 at 2:28 AM
That's OK, I'm ignored all the time.
Field Researcher
#10 Old 30th Oct 2017 at 5:18 AM
I've seen a lot of bugs in TS2 lately, yesterday Darren Dreamer turned invisible for a short time then after i quit and went back in the game he came back, i have a bug with connecting stairs so i can't use them it's only meant to stop you from putting them in if windows are in the way but it's not liking walls either but even when i remove the walls they then don't want to be placed *shrugs*.
Turquoise Dragon
staff: senior moderator
#11 Old 1st Nov 2017 at 12:12 AM
Put moveobjects on. I think apartment life or mansions and gardens did something? Maybe somebody can remember
Back to top